Foundry Partitions & Buttons

Hi There,

Having some functionality issues with the partitions stack when using buttons and on the mobile view…

for some reason when the partitions menu is collapsed and displaying on mobile is causes foundry buttons to do the following

Screenshot 2021-02-27 at 10.43.33

It seems to go away if I place a paragraph stack above the button stacks within the partitions section but seems very strange.

I’m guessing this may be a question for @elixirgraphics :slight_smile:

UPDATE: The paragraph also has to be over a certain amount of text in order to break the buttons from displaying in their collapsed state! Also this only seems to be an issue with the sidebar assigned on the left not on the right!

Hi there @ablx

Please send me a ZIP file containing your project file. Email it to adam at elixirgraphics dot com and point me to the page in question.

If the project file is larger than 3mb or so you’ll need to use WeTransfer or a similar service to send the file.

The problem lies in that you’ve enabled the Shadow feature for the Button stack. It may seem innocuous, but shadows can be a bit of a problem in Stacks. Stacks wraps everthing own the page in multiple <div> tags and then applies overflow: hidden to each of them. This overflow attribute prevents shadows from being shown outside of their own stack. To combat this developers have to use code to disable the overflow attribute on the element and its parents elements so the shadow can be seen.

You use of it inside the sidebar is turning off the sidebar’s needed overflow attribute, and the content is becoming visible.

Now you’ll say – But I have “Disable at Mobile Breakpoint” checked. Shouldn’t that fix it? Unfortunately that can only hide the shadow. The javascript that applies overflow: visible to the stack and its parent stacks is still active.

Why this isn’t happening with the right-hand placed side bar I’m not sure. I’ll have to dig a bit to find out. But considering it is Saturday and I’ve not even had a cup of coffee yet, that is going to have to wait. :stuck_out_tongue_winking_eye: :coffee:

TL;DR – For now, turn off the button shadows and you should be A-OK. I’ll look and see if there’s not something I can do to allow the shadows in the sidebar though. I do think it should be possible.

1 Like

Super Stuff!

The shadow was indeed the cause! I have de-activated that for now and all is working great!

Enjoy the coffee :wink:


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.