Hide overflow - not

Hi all,

I’m having a recent issue when using Formloom 4…seems to be a new issue as it’s only something I’m noticing now on new sites.

There has been no recent updates to Formloom but there was an update to Foundry a little while ago. However, I’m not sure if that is when the issue started occurring.

On lastest version of all Foundry 3 stacks, I regularly check for updates.
RW v8.9.3
Stacks 5.1.2

The form doesn’t fully display it only shows part then you need to scroll down to see more of the form. Located in a Column stack, I’ve tried setting the Hide Overflow off and also on and neither doesn’t make any difference. Yep…cleared cache.

A few screenshots and link to page below.

Appreciate any ideas on how to fix as it is affecting a number of new sites I’m working on.

Cheers Scott


You could try using a background stack and set the minimum height so the form shows?

Seems like you’re importing a full page into that area using an iframe, which has its own overflow properties.

Probably better to not use an iframe, IMHO.

Hi Adam,

Thanks, I’ve been in contact with Mike from Yabdab.

However, I think I’ve tracked down the culprit.

I have created another page Contact Only and started with just the Formloom 4 stack. Then added each component back in again, the issue occurs when I place the Equalize base stack onto the page.

The thing is I don’t have any Equalize Items within the sections of content where Formloom 4 is placed, so Equalize base should not even be looking in that column.

I’ve sent this info to Mike at Yabdab as there seems to be a conflict occurring between Formloom 4 and the Equalize base stack.

Any thoughts on why Equalize base stack may be affecting the Formloom 4 stack height when not placed within an Equalize Item?

Many thanks

No, sorry I do not have a guess as to what is causing your problem. I don’t own FormLoom. If Formloom is its own page, being imported into the page somehow I would suggest trying a different approach that uses a Form that can be added directly to the Stacks page. Try the Foundry form tool and see if that works.

Hi Adam,

Thanks for the reply.

Maybe I’m being naive…I had always believed and hoped that the developers in the RW community worked together with users such as myself to fix issues that arose between the various platforms, stacks and plugins.

So I was hoping for a more collegial way forward, and that between you, Mike from Yabdab and myself we could sort the issue. I am sure I’m not the only person in the RW community that will experience this issue.

Formloom 4 plugin and the Formloom 4 stack offer many features that other form stacks do not…which is the reason it is my go-to. Yes it is a plugin and uses iframe to integrate into a page but I’ve been using it for many years in similar situations using Equalize in Foundry v1 and v2 plus Source and Foundation.

Mike, has said in his advice to me “Something on that page is breaking the javascript Formloom uses to adjust the height of the iframe.”

Yes, I am aware you don’t own Formloom, however, there does seem to be a conflict between Formloom and the Equalize stack and believe that a cooperative approach could help solve the problem.

I’d really appreciate any thoughts you may have to assist either Mike in an update to Formloom or a future update to Equalize.

Best regards and thanks,

I believe you mis-understood what I had to say to you previously.

I literally meant I don’t own a copy of FormLoom so I cannot test it for you. I did not mean I’m not the developer, I meant that I don’t own a copy of the addon. Without it I couldn’t test it for you if I wanted.

It seems like Mike though has narrowed in on your problem.

Ahhh, sorry mate. I thought you were being unusually blunt…which is unlike you. :innocent:
Yes…I misread what you meant in that you don’t actually own a copy of Formloom.

So, my apologies if my response came back a bit jaded.

Yes, Mike feels “something” in Equalize is causing the issue but he may be stuck on what that “something” is…could you please possibly shed any more light to help Mike?

Cheers Scott

If it is a JavaScript conflict it would not matter if For Loom is inside or outside or Equalize. A erro would stop the rest of the JavaScript on the page from functioning. Sometimes things just are not compatible with one another.

Hi Adam,

Thanks for the advice.

Mike at Yabdab has said he is working on Formloom 5 which should be out next year and that as Formloom 4 has been stable for quite a few years across platforms including Foundry 2 and the Equalize stack in that version that unless there are critical errors in Formloom 4 he isn’t planning any further updates.

Formloom 4 does work fine within Foundry 2 and the Equalize stack in that version, so I’m trying to understand why it doesn’t in Foundry 3?

Except as you say “Sometimes things just are not compatible with one another.” …which is a shame, as I love Foundry 3 and I use Equalize regularly and I also love Formloom as my form tool.

I have asked Mike if there is a possibility he can provide you with a copy of Formloom 4 and the Formloom stack so you may be able to test.

I really appreciate your assistance…though it seems like this incompatibility will not be an easy fix.

Have a great day.

Cheers Scott

I just revisited your site to do some troubleshooting and it seems to be working as intended:

I take it you sorted things out?

On your page I see no javascript errors only this error for your form:

Hi Adam,

Thanks for having a look.

No…sadly not fixed. I had just removed the Equalize stack but have since put in again and experiencing same issue again.

Here is link to the project file if that is any help.

Many thanks

Have you thought about maybe using a Height stack instead, just to see if you have the same issue?

Hi Arlenj,

Thanks for the thought, yes I did try the Container stack that has a Custom Height option but that didn’t seem to have any affect.

Cheers Scott

So I can’t see what the javascript error is you were referring to previously. These are the only errors showing on your page right now:

The current URL (Team) does not have Equalize on it, right? I see you have an Equalize Item, but not the parent stack on the page. I ask because apparently FormLoom will not show in Preview Mode so I cannot troubleshoot it from RW:

Hi Adam,

Definitely have the Equalize stack on the page currently. Screenshot taken a few minutes ago.

You are correct about Formloom not displaying in Preview…needs to be published.

These are the errors I see on your page. This error (indicated by an arrow) seems to indicate a JS file is missing for FormLoom.

I’m unfamiliar with this library as I’ve never used it. So I’m unsure if that is what is causing the error right below it or not. I suspect it might be. If so that would be something Mike could look at perhaps. As I said I’ve never used seamless.js for anything so I am completely unfamiliar with it.

I spent a lot of time troubleshooting this. Currently it seems both Equalize and the FormLoom stack (inside its Seamless javascript) share a function name. I’ve messaged YabDab and will wait to hear back from him.


That’s some serious digging to find something like that.

1 Like

Hi Adam,

As usually…you provide amazing service and support!

One of the main reasons I use Foundry almost exclusively to build my clients websites.

Hopefully Mike at Yabdab will come to the party with some thoughts to move forward with the issue.

Mike has said both Formloom and Formsnap are being worked on at the moment for version upgrades and I guess it will be important to ensure same issue is not carried over to these coming versions.

Cheers and thanks again.