How to change html lang "en" to "tr"?

Guys, I want to change my HTML lang to “tr” but I can’t. I changed the override lang setting to Turkish but when I look to source code it still shows HTML lang as an “en”. I also tried from Rapidwear page and foundry base lang settings but it didn’t changed either. is there any way to change html lang? Thank you.

Good morning @telepati

This has been touched on in the forum several times in the past. I’m going to link to a few posts below that touch on the topic for you. In the future don’t forget to use the search feature at the top of the forum to see if your topic has been covered already or not. To find these posts I used the search term language in the forum’s search tool:

1 Like

Thank you. I follow the instructions and in the local server shows ‘tr’ but when I published it still shows 'en". Why this happening?

Source view;

Preview In Safari;

Screen Shot 2020-08-02 at 18.42.33

After Published on Server (Cache cleaned)

Screen Shot 2020-08-02 at 18.42.57

The file on the server does not change. It will always be set to en. The content changes during page load as I describe in the other posts, as you’re seeing in your second screenshot.

If you have a link to the live page I will show you.

Actually, I changed all as a “tr” on the server. Did I something wrong?

Ok. I republished and all changed to ‘en’ again. Here is live page;

Foundry has a setting for the language in the main control center stack, as outlined in the documentation. You set the language property there. If you change it on the server it will be overwritten each time you publish. The setting in Foundry’s control center stack applies the language property during page load.

1 Like