Image upload error

I’m having an issue uploading an image to a blog entry. I’ve uploaded a Topper image no problem. When I try to insert an image in the content area I get an error. The image is a .jpg and is 733KB in size. Not sure why it’s failing, is there somewhere I can look that might give me an idea of why it’s failing?
Screenshot 2023-06-09 at 6.16.17 PM

Web safe? No spaces or special characters in the filename?

I just renamed it to one word but it still errors out on me.

My initial thought is that the filename you’re using is a sentence and not a filename. Try something short and to the point – septic-cleaning.jpg for example.

That said also be sure that the file really a jpg image. It can happen that an image gets saved out as one format, but with a different extension. Open it in your image editor and resave it (I’d suggest Photoshop’s Save for Web feature) as a jpg just to make sure. While you’re there, before saving, make sure it is 72 dpi and RGB.

Also, compress said image. 700k+ is quite large.

Always so many things to keep in mind when working in the web.

1 Like

Yeah, I’m not sure why I was trying to upload a 700k image, my bad :man_facepalming: I reduced the size and it was still given me the error even after I shortened the name, so I logged into my hosting provider and I’m greeted with a message saying maintenance is underway on servers hosting several of my websites. That’s most likely the issue.


Let me know if you keep having problems after your server’s maintenance completes.

I continued to have the issue after the maintenance completed so tried changing the image format to webp and it uploaded just fine. Not sure why it doesn’t like .jpg’s. I tried some other .jpg images I had just to make sure the image wasn’t corrupt but none of them would load either.

JPG images are perfectly fine. That’s the primary image type suggested. I suspect there’s something up with your JPGs then. I’d you want to share a ZIP’d folder of your JPG images I’m sure we can look at them. (73.0 KB)
here’s the image I was trying to upload, thanks for taking a look.

I have the same issue like that. After I covert file format to WEBP or tiff, It looks fine. I do not know why?

It’s hard to see this as an Alloy issue. Myself and many others are using JPG images with zero issues.

What versions of RW, Stacks, Foundry, Alloy are you using?

Which version of MacOS?

Who are you hosted with?

Which version of PHP is your server running?

@elixirgraphics Are there any specific PHP modules required to be active?

I suspect it is in the way you’re saving your images perhaps. I threw your image through a file type identifier and this is what I got:

I then took your photo into Photoshop and saved it out for web, then ran that image through the same identifier:

I’ve included the image I saved in Photoshop below. Download it and try using it for your upload and let’s see if that might be your problem. It’ll give us a place to start.

Download: - Droplr

Not for the upload of them image itself if I’m remembering off the top of my head.

1 Like

@elixirgraphics It must be my hosting provider. It’s giving me the same error when I tried to upload the image you sent me. I also tried it in a browser I don’t normally use so there wouldn’t be any potential cache issues. I plan on reaching out to my hosting support to have them take a look.

@elixirgraphics After reading @jacksona comments I decided to take a look at my php, I was running 8.1.20 so I bumped it back to 7.4.33 and now it works fine. :thinking: above my pay grade…lol

1 Like

Should work fine in PHP 8 as well. I suspect something with your PHP 8 install. Do you have a PHP error log you can share with me from when you were having the issue?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.