Open Graph Meta tags in Alloy blog posts

This issue concerns the posting of a link to a blog into a tweet in Twitter.

When I add the relevant URL into the tweet the Twitter card will show the relevant text but the blog image is not generated. Is there a setting in Alloy that I need to apply to generate the appropriate Open Graph meta tag?

Many thanks.

That’s weird. Since you didn’t provide a URL for testing I loaded up the Foundry blog, which uses Alloy, and the topper image populated. Does it here on Discourse as well:

Have a link for us to look at? Also, please create a ZIP file with the image you’re using as the Topper Image and upload that as well.

Make sure Generate Social Tags is OFF in the RW page inspector for your Blog page. Leave Alloy to handle the tags, otherwise you’ll end up with a clash that causes this issue.


Adam, thank you for getting back so swiftly. I am now starting to believe there may have been an issue with Twitter.

A couple of hours before writing my post (and after attempting a number of tweets) I tried using Twitter’s ‘Card Validator’ ( It was also showing the same error i.e. no image upload to the card.

A couple of hours after writing my post I again used Twitter’s card Validator and this time the text and image were uploaded to the card correctly. I then tried a tweet and it also uploaded correctly. I hadn’t changed any settings and have no idea how everything appears to be working.

In short, I believe I have wasted your time although I have now discovered that it appears Twitter can be a little flaky.

Thank you for this. I did have the Generate Social Tags switched ON as I thought this was the appropriate setting. I wasn’t aware that Alloy handles tags in its own way although I should say that I have managed to get a normal post to upload (text and image) without switching the Generate Social Tags OFF.

I am confused but this is the ongoing joy of working with websites :thinking:

I spoke too soon.

If you’re still having trouble and think it is Alloy related, be sure to share the information requested earlier. :+1:

If you haven’t done so, I’d switch ‘Generate Social Tags’ to off as suggested by @jacksona. You likely have two Open Graph meta tags being generated: one by RW and one by Alloy. Twitter may not always select the correct one.

1 Like