PaySnap page and child pages disappeared

Copy/paste from Realmac topic – I’m at a loss. These pages are gone from every active, backup, safety copy, etc. Like they never existed. I have a ticket with PaySnap (Yabdab) also, but that’s not going anywhere. Foundry

I’m not a pro, I’m not a network specialist, I just get by.

I assume this has to do with a recent NAS upgrade (although I don’t understand how).

One section of (Foundry based) site is PaySnap page with two or three sub pages.

A client just told me “I tried to pay you, but there’s no payment portal on your site anymore.”

It’s true - that entire section is gone from the web site. It’s ALSO gone from the Rapidweaver file. So in a bit of a panic, I opened an older file. Also gone. PaySnap is in the stacks - But the page (and it’s sub pages) have just plain vanished.

Luckily for me, on the last publish, it didn’t delete the old page from the server… So I added a link from the home page.

December is usually a pretty big month - I’ve been wondering why I’ve had literally ZERO new business - Now I know why. Anyone ever experience anything like this? I assume it could happen with other stacks / add-ons / whatever… At this point, I even needed to rename the new NAS the same as the old NAS just to open the (what should be contained and complete locally) RW file (obviously it’s still trying to connect to the drive for some odd reason that I can’t figure out).


You can see the MIA pages through the PaySnap page (needs to be updated - but for now, I’m happy that it even exists):

PaySnap – is that a Stacks addon or its own page type?

That said, Foundry has no control over adding or removing pages from a project. This is something that the app would be responsible for as I don’t believe anything besides the RW app can add or remove pages from a project file to my knowledge.

As @elixirgraphics has said, only RW can remove pages (certainly not Stacks or Foundry), and I’ve never come across that happening, at least not without it being a manual thing, whether deliberate or accidental.

From an IT perspective, something has changed, and it’s not clear from your post what the NAS’ relevance might be, but since it’s obviously important enough to mention, that’s where I’d start looking.

1 Like

@JohnScrip I’m sorry you are running into this problem, but as @jacksona has mentioned … it’s worth looking at your NAS setup. I’ll confess I don’t know exactly how a NAS works but I have sometimes heard of users having a similar problem with Dropbox or iCloud.

First, and foremost, you should have the backup option within RW turned on. (Perhaps you do … in that case you may be in great shape.) Go to Settings > Pubishing and make sure the backup frequency is “activated”. I have mine set to once a day, but there are several other options. Unfortunately the default setting is “never”. I personally think this is a mistake on RM’s part but it is what it is. You’ll notice, if you have this activated, that you can download the backup from within RW.

Second, and this doesn’t help right now, is I always tend to archive critical work projects. I do this by renaming the same project file based on year-month. So I’ll have my-project-2023-12 as an example. Then I’ll also have my-project-2024-01 in a few weeks. This provides a high level of protection as sometimes I may have backup up a “bad” project file and I really need to go back to an earlier version. This might help you moving forwards.

Third, and likely the most unintuitive part, is a RW project file isn’t really a “file” in the way we think of a Word document, or markdown document, etc. To us it looks like a folder … but that’s really a disguise. Right click on your project folder and you’ll see you can open it up. So it’s really a folder that contains several other folders and files. In normal use this isn’t a problem. But … for special services like Dropbox, iCloud, and perhaps NAS they’ll sometimes see these “project files” as folders. The consequence is chaos can ensue.

I do use iCloud for storing most of my RW project files but I’m comfortable since I have a good backup system in place. And these kinds of issues don’t happen a lot but they do seem to happen once in awhile.

If you are really sharing work with another person (I think that’s one reason for a NAS, but I may be wrong) then a safer way to store is to first zip your project file and then upload to NAS. (Maybe this isn’t possible with NAS, but is with Dropbox and some other services).

Sorry I don’t have better news for you. Obviously the real issue could have been something else and I’m completely wrong. But I have seen similar issues pop up for others.

Holy crap - You struck a chord there - And you’ve given me yet another chance to stumble my way to success.

One thing I started worrying about immediately is that whatever was going on was “spontaneous” (for lack of a better term) and permanent. So I started making copies of the files before I tried opening them.

Just now, I started looking at package contents - Every file I’ve opened has no rate sheet group in the plist files. Not there, period.

So I made a copy of a file I haven’t opened and looked at the plist files - The group IS THERE. Then I opened the file in RW. No group. Checked package contents again and the group IS GONE. However this is happening, that data is being wiped out when I open the file.

SO - I made another copy and checked contents again. In the plist files, there are many references to “RATES002C-ETC.” (the page is called Rates, ETC." in the menu - with that period on the end). But there’s no period - I scraped every plist file I could find and removed that period. One by one, those pages returned.

I guess this has nothing to do with the NAS. I’m not sure what’s causing it all of a sudden (that page has been called “RATES, ETC.” for years. And these files have never lived on the NAS anyway - but all of a sudden when I was trying to open them, RW was yelling about not being able to access the NAS drive.

Anyway - I have hope. Thank you. The pages are old and need to be updated, but it’s better than trying to rebuild from scratch. That rate sheet took me days (again, I’m stumbling my way through).

Now I have to figure out how to import pages from another file. I think that’s possible… Hopefully I’ll stumble into that also.

1 Like

Weird for sure, but I’m glad things are starting to work out for you! I hope all gets sorted.

1 Like

Just uploaded. A lousy dot (.) caused the whole thing. Thank goodness I kept those archives… And thanks again for the tip on checking the package contents.

I’m desperately trying to take a few days off - and then this happens… I figured I’d be spending all that time trying to rebuild from scratch. So you’ve inadvertently saved Christmas. Huzzah!