Pop Up Menu in F3 on Mobile

Hi Adam,
I am creating a one-page website using F3 - Partition and Pop Up Nav Menu, the Popup Nav is not working on mobile, but it is working fine when viewed on a laptop/iPad, once click on the link it goes to the actual section in the page, but not working once viewed on mobile (the link does not go anywhere)

What would be the issue?

Well all need at minimum a link to your trouble page to be able to help. It would also be of help to have your project file on hand as well.

Thank you Adam for your reply. Here you are the link:

Please note, I could not upload the RW-Project here due to the size limitation, so I’ve sent it to you via We-Transfer, hope this is OK.

Appreciate your feedback on the issue.

Better if you post the download link here as I’m away tomorrow and won’t be able to look at this straight away. That way if others are around they might be able to assist you as well.

It looks to me that the links are working, you just need to close the modal/sidebar in order to see it (and the close button is dark so it is hard to see it). I’m not sure of the fix for that but I don’t think it is the Popup Nav that is the issue…

Thank you @jabostick your message is making sense that’s not the Pop-up Nav…I have tried couple of things, but still the same… same here I am not sure how to fix it.

I haven’t used Partitions before. Can you use the default navigation that comes with it? If you visit the documentation page (Partitions) and try it on mobile, it works as you’d expect it. It doesnt have the styling of the pop-up nav, of course, but should work out of the box

Edit: Sorry, I’m ignorant of Partitions. It doesnt look like it has its own navigation. The documentation page just uses a list/set of links, it looks like

Deleting all my previous comments due to my own ignorance/misinformation lol. The Partitions used on the document site and on the Documentation starter project don’t use single page navigation, so they don’t behave the same way as your site. I will leave it to the pros to come up with any suggestions.

@jabostick No worries at all! thank you for trying to help :slight_smile:

After re-reading what you’re trying to do, and getting to look at your example, I can tell you that the navigation tool you’re using – Popup Nav – was not designed to do what you’re trying to do with it unfortunately.

@elixirgraphics OK…Thanks Adam!