Problems with md-Files

I write my NEWS articles in Ulysses and transfer them to the ALLOY folder via FTP.

My problem is that the articles are never displayed on the HP via Alloy on the first try. For me the articles are written correctly and Ulysses also creates a correct .md file. Obviously, Alloy always interferes with some sign or something.

Here is a .md entry which is not displayed on the HP (see hardcopy). Please help, it is very tedious because I always have to edit every post in the FTP folder.

:slight_smile: Gerhard (1.1 KB)

Hi there @Gerhard

I’m to sure what you’re referring to here with “HP.”

I suspect that your editor is not using a line ending that Alloy’s YAML and Markdown parser does not read.

I don’t rent Ulysses so I can’t do much testing. If The app has a way to choose line endings, allowing you to choose between LF, CR, or CRLF I would give that a try. It likely uses CR or CRLF I would guess. Try using the LF option if the editor allows you to choose. If not then you may not be able to use that app for creating Markdown files for Alloy.

Also make sure that if the app allows you to choose the Markdown type that you’re using standard Markdown and not a variant.

In what way are you editing it via FTP? What app launches to edit the file when you edit it from your FTP app?

All that said, the easiest way to use Alloy would be to simply use the Editor that comes with Alloy.