Receiving a 404 error for rss.xml file

Hi @elixirgraphics Adam - in whatever browser I copy and paste the following rss.xml file into I seem to be getting the same error message. I have tried Safari, Firefox, Google etc .This is despite following your video tutorial on the subject. I’m just trying to understand the benefits of having an RSS link on a website if it just directs the visitor to a 404 page not found error message. Can you recommend a resource that sheds some light on this topic ?? Thanks . Justin

I’ve created a new thread for this post as you replied to a thread that was 3 years old and only partially related to your problem.

An RSS feed is for use by RSS readers. Something like NetNewsWire or the like. If you’d like more information on what RSS feeds are or what feed readers there are available I’d suggest a Google search.

As for a 404 error being returned – It is hard to diagnose anything without a live URL and a project file in hand so we can see how you’ve set things up.

To give us access to the project file you’ll need to create a ZIP file containing your project. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply along with the link to your live URL.

Hi @elixirgraphics - and thanks for investigating this. Apologies for this being such an old enquiry but de in part to my current workload and requirement for RSS from an existing client ave only just go around to raising this topic again. I have sent you the project in question via WeTransfer to your : in the absence of any email address to reach you on.The link is : [](WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free)

Kind Regards | Justin

Hi @elixirgraphics - the live URL is : Kind Regards | Justin

As the email address implies ( that address goes absolutely nowhere as it is a no reply email address – that is why the instructions above were to place the download link here in your replay to my post.

As for why your rss.xml file is missing… you’ve not enabled that functionality in your Alloy Control Center:

Hi @elixirgraphics . Thanks for your prompt reply. On looking at my project it would appear that I do have the ‘Generate RSS Feed’ turned on at my end ( see attached screenshot) Just in case I have sent you the incorrect project file, here is version 001(19).

[](WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free)
Kind Regards | Justin

You can download the project file you sent initially, in this post and have a look:

That said, with it being the weekend, and my wedding anniversary today, I won’t be back in the office until tomorrow. I can say though that I visited this URL just now in NetNewsWire on my phone and there is indeed an rss.xml file present:

Hi @elixirgraphics - Ok so I think I am slowly starting to unravel the ‘mystery’ behind this RSS stack and how it is presented to the general public. If I understand the concept correctly I have to copy and paste the URL featured as part of this stack into a third party application like ‘NetNewsWire’. I must be honest with you, I was led to believe that clicking on it it would send me to an associated RSS feed - or some other supporting web page. I too have just performed a test in NetNewsWire and all worked as it should. Thanks you. I will be recommending this to all users of the domain that I shared earlier not click on the RSS button that is part of the Alloy and instead advise them to copy and paste the associated URL into their RSS reader of choice. Other than NetNewsWire can you recommend any others that align with the Mac (Safari). #opentoideas. Justin :wink:

If you have an RSS reader on your Mac it would launch that app. But that is between you and your apps. Alloy has zero control over your work environment.

As for other RSS readers — do a quick Google search and you’ll find aplenty. It’ll come down to your own personal preferences. They all do generally the same thing.

I’m ditching ‘Feedly’ @elixirgraphics in favour of something simpler :wink:. Thanks for your help.

Despite installing the NetNewsWire extension into my Safari browser I just wanted to let you know that I’m still getting getting the 404 error message. If it doesn’t correct itself anytime soon I my have to delete the RSS stack from my website as I’m struggling to see what the benefits of it are at the moment. P.S Happy anniversary

What page are you visiting that you’re getting the 404?

The feed exists on the blog page:

HI @elixirgraphics - trying to open it from the home page -

That is not where the feed lives. As I mentioned above: The blog feed lives on the blog page. Your blog’s feed doesn’t exist on the home page.

If you want to link to the feed from the front page via the link pictured below then change it to the feed on the blog page:

Needless to say, Alloy is working as expected, it is just that I think there has been a misunderstanding on your part as to where the feed lives.

Hi @elixirgraphics - ah That would make sense now. As this is a ‘stack’ I assumed that this could be applied to any page. Thanks for putting me straight :wink:

Whilst I have your ear , and no doubt you will now move this thread to another (sorry) - can you tell me when , now that Isaiah at Yourhead has confirmed that there is support for Font Awesome 5 in the latest version Stacks , are we are likely to see this in Foundry ? Sorry to be a pain but I have clients wanting the TiKTok icon . Kind Regards | Justin

The RSS feed tool in Alloy is for the blog page only. This is that standard place where feeds are placed. You can make a link to the feed from any page using a standard link, button, etc.

You know you too could make a new thread… :wink: :wink:

I’ve not heard about this. If you have information about it I’m glad to take a look. That said, FA5 is planned for a future major release already.

Screenshot 2022-11-28 at 18.06.04

From the Rapidweaver thread entitled :

What I said above still stands: