Scroll To stack not working

Hi Adam and everyone,

I’m having issues with the Scroll To stack…it works on RW Preview and also RW Simulate but once published it doesn’t work in Safari, Chrome or Brave but does work in Firefox browser.

Yep, cleared cache and checked I have matching Target Id’s - as mentioned works in Preview mode great but not in the actual browser except Firefox.

Also doesn’t work RW Cmd p shortcut either.

Any thoughts please…link to page here.

It is the “Some comments from our customers” button in the first white text section.

Thanks Scott

Scott, the issue is that there is a stack with a z-index of 9999 that is forcing all of the container stacks above it to also get that same z-index value. That is higher than the z-index of the Scroll To stack, so it is overlaid on top of the Scroll To stack. Since technically the Scroll To stack is behind these other stacks (even though they are transparent) they are preventing you from clicking on the Scroll To stack.

It looks to be coming from Yuzool’s Navigation stack. By any chance, did you set the z-index on that to 9999? If so, try try dropping it to 2000 or below.

If you can’t figure it out, we may need to see a project file to determine why that has a z-index of 9999. If we can’t fix it that way, then we can provide some CSS to increase the z-index of the Scroll To stack

1 Like

Hi Don,
Yes, that would be it. I had to change the Yuzool Navigation stack z index to 9999 for another reason. I have changed it to 2000 and also tried 1999 but same issue, doesn’t scroll down.

So, I have removed the Scroll To stack and put in Anchor stack instead which does work. But I’d prefer to see a Scroll down effect rather than jumping straight to the section. It is better for clients to see that they have scrolled down the page rather than not knowing where they have jumped to on the page…gives them an understanding of where there are located on the site.

If you have any ideas on how I can implement a Scroll effect it would be greatly appreciated otherwise I will just have to stick with the Anchor and a jump to that section of the page.

Cheers Scott

After you changed the z-index in Yuzool’s Navigation stack, was it not working in preview or live? If live, you may still have been using a cached CSS file.

I put Yuzool’s Navigation stack on a Foundry page with a Scoll to Top stack on it. In my test, I could not click the Scroll to Top button. Yuzool’s Navigation stack defaults the z-index to 9999. When I changed it to 2000, the Scroll to Top button worked fine.

The only way we’ll be able to troubleshoot further is if you went back to the Scroll to Top stack and set the z-index to 2000 in Yuzool’s Navigation stack. With those changes made and published, we can look again to see what’s going on.

1 Like