Shutter Stack Not Displaying Thumbnails


I’m developing a website for a friend - I’m trying to use the Shutter stack in batch mode. I notice (using CyberDuck) that the batch and thumbnail folders have been created. I’ve uploaded the images I wished to use but nothing! No images are displayed on the webpage, and I cannot get access to the gallery.

I’ve checked - the server is running PHP 7.4

The webpage is Galleries | Sophie's Dressing Service (note it’s still a work in progress, but before I get any further, I need to get SDhutter stack to work!)

I’ve been happily using the Shutter stack in batch mode on other websites. I can’t work out what’s gone wrong here.

Also, is there a minimum file size on an image to generate thumbnails (some of the images I’ve been supplied are possibly smaller than thumbnails) - may this cause issues? [But note: I’ve removed these smaller files to see if this was the problem.]

Many thanks in advance.



I’ve used a different browser (switching from Safari to Chrome), and the images have now appeared. I’m assuming that this should have worked on the Safari browser?

Works in Safari for me and looks identical in Chrome.

Yes, thank you for confirming it works in both (a relief!) However, it wouldn’t set up the thumbnails etc. until I had viewed the page in Chrome.

Thumbnail generation happens via PHP which is executed on the server side of things and should not be browser dependent in this case. If you can reliably recreate this problem in a repeatable way I’d be happy to receive a copy of your project file and original images, along with the steps to recreate the problem so I can look at it.

All very odd. I’ve removed the galleries completely and started again. And yes, I have been able to replicate it!

Safari will generate the batch folder, but not the thumbnails! Chrome has generated two out of three sets of thumbnails, but one set has been left untouched.

I’ve noted that I have an error in Safari: ‘Failed to load resource: the server responded with a status of 404 ()’ - the missing file is /img/loading.gif - this is very confusing as I had no idea there was a gif file on the page (it’s not one of the files in the gallery). It’s also a very small 3.2kb file.

What’s the best way to send the project file?

As I said before the images are processed server-side. I think as important as the project file, or maybe more, is seeing the original image files you’ve e uploaded via FTP to your site.

Provide us a copy of your project file as well as a folder containing all of the images which have failed to be turned into thumbnails.

Create a ZIP file containing these items. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Hi Adam,

I’ve sent a link to download the ZIP file from my website to your email.

Many thanks

Replied. Let me know if that fixes it for you.

For any who come across this in the future –

The problem was that the files were named with all uppercase extensions (ie: .JPG). Switching them to lowercase extensions (ie: .jpg) solved the problem. I’ll have a look at this in the future to refine it a bit. Until then just be sure you’re using lowercase file extensions.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.