Table (CSV) Sort not working as I expected!

I’m working on a site for my wife for some of her dances. I’ve built an index page of those dances using Foundry Tables(CSV) which up to a point works great. Because my wife doesn’t have access to the internet where she is doing her dances I’ve loaded the pages into an iPad app called Offline Pages. The Foundry Table(CSV) doesn’t show up in the Offline Pages app while the other Table CSV stacks that I have do. The other Table CSV stacks that do show up load the table using php on page load, at least as far as I can see. The wife loves the sortable aspect of the Foundry Tables (CSV) so I thought I’d build the table within the page using the plain Foundry Tables Stack, though a long tedious job, this did work within the app on her iPad. My problem now is the table sorts, not on the Name of the dance in the cell but on the link address that I’m using with Joe Workman’s Anchor. With this anchor I can link to another page and an anchor farther down that same page.
The table Sorts as (not actually the site if you didn’t guess that on your own):

rather than table content (Commas are just to show the different cells):
Arizona (Iced Tea) Stomp, Seven, 1, 2
Who’s Your Daddy, Seven, 1, 1
Write This Down, Seven, 1, 10

There aren’t that many options within the stack and I don’t want to go back and change all the anchors, we are talking hundreds here! Any help would be greatly appreciated!

Hi there @dks0035

I’m unfamiliar with the Offline Pages app you mention. I’m not sure what browser engine it uses for rendering pages. I would assume it uses the Webkit engine, or an offshoot, but that is just a guess. Having not used it before I have no clue, whether that is the case.

I have some questions regarding your setup:

(1) Does the Table and / or the Table CSV stack work within a normal browser for you? Like Safari or Chrome for instance.

(2) Do you have a live URL we can examine? Or, better yet even a ZIP file containing the project file for me to have a look at within RapidWeaver.

(3) What version iOS are you using?


(1) I’m getting the same result using Safari or Chrome on my iMac using High Sierra

(2) I’ll pm you a link as the site will be for personal use only but I don’t mind you having a look.

(3) I’m using IOS 11.0.1 but this is happening using any browser on High Sierra I don’t think that is a concern.

(1) I’m getting the same result using Safari or Chrome on my iMac using High Sierra

Have you tested on other machines that are running anything other than High Sierra?

(2) I’ll pm you a link as the site will be for personal use only but I don’t mind you having a look.

Also send along a ZIP file with your project file inside of it, please.

So I loaded up your project file and couldn’t get the CSV file to load from your remote URL. I suspect it is due to a CORS problem. So I downloaded the CSV file and saved it locally, adding it into the RapidWeaver Resources. This is one of the ways (the main way) of using the stack that I look at in the tutorial video. I then linked the stack to the version of the CSV file that is located in the RW Resources. Note I didn’t change the CSV file itself in anyway.

I had to move the Table stack out of the other stacks on the page as I don’t have them and it was preventing things from displaying properly because of it. So if you notice the page looking weird, that is why. But since we’re testing the Table stack itself right now, we’re good to go there.

I made this video showing sorting working on all columns within preview:

Is this your same experience in Preview Mode?

So I did a live preview in Safari and get the same results:

Either one of the stacks on the page that I don’t have is causing a problem, or something else that I’m not running into here is a problem. I suspect it might be the former.

My suggestion would be to make a very simple test page, placing just the Foundry Control Center and the Table stack on the page and seeing if you encounter the problem. If you do not, then it is likely one of those other 3rd-party stacks your using on the page, that I don’t have access to, that is causing a problem.

Within the project file I sent you I had a page called sortable with just a foundry stack, nav bar stack and the table csv stack and I still had problems so I felt the problem was not a conflict with another stack.

A couple of Rapidweaver updates back I had a problem with the resources part where I had to go back and relink all the resource items to the file on my iMac. I found it quite tedious after a couple of projects so I stopped using the resource section of the sidebar in Rapidweaver and began linking directly to the file using the Copy URL option in Transmit. Everything has worked just great up till now.

After watching your video I went back into the project and deleted the link to the physical csv file and linked it as an asset. When I tested the page in preview the sorting worked perfectly.

I hate turning over this much control as to where I place my content to Rapidweaver but compromise can work on occasion. Thanks for your help.

Linking to a file on your server is essentially the same as using the Resources. RapidWeaver is just uploading the file for you. So if that is working then it should work with your file on your server as well, providing there’s no problems with the file and you’re not having any CORS issues.