Unable to update Foundry ( ->

Correct the uncompressed Foundry install is larger than 7.2mb… through the magic of file compression the update is delivered as a smaller 7.2mb file via the updater and then expanded and installed.

Nothing wonky going on. :+1:

BTW, many many thanks for all these fixes and tweaks. Very much appreciated!

1 Like

Hi Adam,
thanks for your rapid and appropriate help.
Your recommendation helped immediately – RW crashed – but after restarting it was updated.
I’m working with
RW Version 6.4 (15176)
Stacks 3.2.7
Updated Foundry, and
I think, I checked all buttons to update…
Good Work.

1 Like

Glad to hear the suggestions are working for some of you so far.

If you had problems with the update and you try the suggestions I made above, let me know how it turns out for you, if you haven’t already, so we can maybe narrow in on the problem and see where the hangup is at.

Good morning. On my side the update was done without problems today (failed yesterday though), it was not necessary to apply Adams’ suggestions.

1 Like

@peppermint – That’s good to hear! Maybe the server was playing games on everyone over night. Just glad things are going well now.

Hi all,

It sounds to me from the most recent feedback (and my own testing) that whatever internet poltergeist was causing this has evaporated (for now).

But if anyone does experience this again please let me know. If you reach out to me here, on twitter, or via our Stacks Slack channel I’ll get back to you almost immediately.

Other details that would also be helpful:

  • where you are in the world right now
  • what your current internet speed is: measure with http://speedtest.net

i can mimic some of these conditions with dev tools and see how that affects things.

I believe there was also a crash reported. I’ve been working on the updater quite a bit for Stacks 3.5. It should be in the latest beta – which should be public on http://slack.yourhead.com any day now.



The new Stacks beta fixed it for me, thanks Isaiah.

1 Like

For future reference…

Tried again this morning (Thursday - East Coast Australia). It worked although it still hangs up as it has always done (different issue - never appears to complete but actually does - maybe related maybe not) But, anyway it is now at

All versions were latest production (no betas) RW 7.4.1 (18708)/Stacks 3.2.7/Foundry

Internet speed? Maximum maybe 2 mbps on a really good day (ADSL 1) but degrades over time. Don’t think this has any affect though.


1 Like

No problems here updating on 2 macs.

1 Like

Did a few stack updates yesterday including Foundry, all worked OK

1 Like