"Unsafe" pages (or images) in Alloy Pages

I am getting a Site Security warning for unsafe images on both my Blog Post page,Post pages and Editor pages on iPad and iPhone. The iMac Chrome browser shows the pages as OK. All other pages on the site are ok on all devices.
I have checked the General and Publishing setup areas and the web address is identical and is an https address on all sites.
Any hint on what to look for?

By are you referring to by unsafe? Are you talking about your SSL certification? Something else? We’re all going to probably need more details and a link to the live URL to be able to assist you.

OK. I am talking about the warning symbol to the left of the web address in Chrome in these pages. In Safari (on iPad) it does not show as a secure address despite the https address.
Screenshot from iPad:

Web address is https://louisalawson.org.au/


You have images on the page that do not have an https:// prefix. The example I found right off is the topper image:

This likely means your settings in RW are configured as http:// and not https://

Alloy’s Editor uses what you tell it in the General and Publishing settings to build the URL for your images when you upload them. If your settings in RW at the time were http:// prefixes then that is what the Editor used to build the URL.

If you’ve not already changed the URLs in your General and Publishing settings to use the https:// prefix, then do that now. Afterwards do a Republish All Files from RW just to ensure everything gets updated.

After that is done you’ll need to open your post in the Editor on your site, delete the Topper Image for the post and re-upload it.

If you have images in your post’s body as well you’ll need to delete and re-upload those as well.

As an unrelated aside – don’t forget to put your forum posts into a category when you create them. This helps others in the future when looking for solutions to problems. I’ve gone ahead and added the category to your original post this time.

1 Like

That did the trick. And you are right … one of the General / Publishing tabs originally had http which is why I contacted you yesterday. I thought once I fixed that it was all ok. This is a steep learning curve at present! :slight_smile:

And “thank you” for the prompt support as well. Much appreciated.

1 Like

Glad you got it sorted out.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.