Alloy blog items don't show properly anymore

Hi. I created a website (Foundry2) with two Alloy blogs in it (with tidy URL’s). Suddenly one of the blogs doesn’t show properly anymore.
After more than an hour back-and-forth, republishing and trying everything within my skillset it still doesn’t work.
The addresses are: memoma | blog and memoma | in de media.
In the last one - /mediablog - clicking on blog-items will not show them properly anymore.
Beats me. Anyone who has a clue?

Hi @jvanodenhoven In the /mediablog it’s like theme disappeared in the blog post. Did you check that ?

The page is set on the ‘Foundry 2’ theme I checked in RW…

Sorry for the dummy question : Alloy control center is still on the page ?

But there was a message in Rapidweaver (that also disappeared already) which I made a screenshot of saying:

Fatal error: Uncaught Error: Call to undefined function curPageURL in
Ox7f7edc775300/RWDocumentPagePreview/mediablog/index.php:1709 Stack trace: #O
/Applications/ include #1 {main}
thrown in
Ox7f7edc775300/RWDocumentPagePreview/mediablog/index.php on line 1709

not my language :wink:

Yes Alloy Control Center is on the page

I think it’s a problem with php server on RW. I’m not on my desktop now. Can you try to disable the php server in RW preview setup (think it’s in preferences not sure poor memory) ? Another question : did your server (webhost)update php recently ?

I’ll try… going to look for PHP settings, RW and serverside

Hi Bruno, server is now set on PHP 8.2 (was on 8.0), and RW was already on 8.2.9
Republished everything, refreshed and still same problem exists…
The weird thing is, the other blog works fine, this one ‘/mediablog’ has obviously a glitch somewhere…
I already deleted the whole content of that folder before in the FTP-client and published again…
but the same problem is still there…
I’ll try that route again - and will backup the posts before (!), and I’ll go to the editor for a fresh new start en reload the posts form the BU

The error is to call an undefined function. It is called curPageURL and it appears at line 1709 of the script. It’s a php error because of the lack of this function. Did you leave and restart RW? If so, have you republished all the files after that?

I closed RW and republished all… but still no result… maybe I should build that specific blog page all over again from scratch? don’t know

Unfortunately, I think the result will be the same. There is probably a cache problem but I am not competent for this question. I think maybe @Erwin-Leerentveld could surely help you if he reads this message. Sorry I can’t help any more.

I understand… and thanx a lot for you swift support Bruno !!!
I decided to roll back to a previous version of the site because we were operating in the live version ;-(
and will set up a new environment on a subdomain to test again…
thanks again!

A last-minute thought: realmac holds its video support in 10 minutes. You can reach them to submit your concern to them live (it’s on zoom and it’s not recorded). Here is a link :
Because I don’t think it’s an Alloy problem. Good luck

the new URL’s are (now in subdomain):

Hi, Sorry to bring bad news, media still doesn’t work. I think you should post on the realmac forum because it seems to me that this problem is related to Rapidweaver not Alloy. The tree appears raw, as if the entire layout were absent, the same for the theme. If the theme and layout are correctly installed on Alloy (i.e. as for the /blog), then it is the php that generates the error. Either because of Rapidweaver or because of the server (hence my question about a recent update). Last hypothesis that can be added to the other two: the cache is not properly cleaned and generates an error loop. But here I am not competent because I have no idea of the infrastructure used by RW or Alloy. Sorry I can’t do more.

@jvanodenhoven — Did the problem begin after creating a new blog post? If so go remove that post from your posts folder in your server via FTP. Be sure to make a backup copy of that folder before doing so.

Also, please send me a DM with your PHP error log file from your server. Your host should have documentation letting you know where to find this.

When I select one of your posts I am seeing the following errors which explains why the post looks like the CSS hasn’t been loaded. Don’t know if this is the cause or the result!

[Error] Did not parse stylesheet at ‘’ because non CSS MIME types are not allowed in strict mode.
[Error] Refused to execute as script because “X-Content-Type-Options: nosniff” was given and its Content-Type is not a script MIME type.

Thanx Wirrah, for your in-depth research, this is definitely not my area of expertise, :wink:
I just send Adam the PHP error log and hopefully he’ll find the clue
Thanx again!

I’m not at my work computer for the weekend, so please try backing up the posts folder for the troubled blog page, then delete that posts folder from the server and re-visit the blog page please.