Eclipse video - foundry 3 conflict

Eclipse Video Stack by Weaver Space isn’t working with Foundry 3.
It used to work with Foundry
Please Help

Good morning @Sree

I’m not familiar with Eclipse, or what it does. That said, perhaps Eclipse requires jQuery? If so that could be the cause. Foundry 3 does not load jQuery for the page like Foundry 2 did. Beyond that I can’t imagine another conflict. That said if you’d like to provide me a sample project file and the Eclipse addon, or a live URL of the non-functioning page, I can have a look. You can send me a direct message here on the forum with a download link to a ZIP file containing the project file and Eclipse, or you can post your live URL here in the forum thread.

I shall send you the Eclipse addon.

Don’t forget your test project file as well.

I did part of it using Foundry and then redoing it with Foundry 3.
So the project is just on the first page.
I shall send you a new project file with Foundry 3 + eclipse video
and another file with Foundry 2 + eclipse video

Eclipse video creates a ‘hero video.’

can you pls send an email id.

I only need Eclipse and the project file of the design that is not working.

Create a ZIP file containing those two things and then create a link to share to them using something like Dropbox, WeTransfer, etc. You can click my avatar and select the Message button to send me a direct message with that download link.

You may please add a video to test the stack.

Don’t post download of other developer’s software in the public forum. I’ve removed the post.

I thought I was only sending it only to you.

To do that you have to do as I stated above:

I’ve downloaded it though and will have a look as soon as possible.

Looks like Eclipse uses jQuery. Foundry 3 though does not load jQuery by default. The reason it would have worked with Foundry 2 is that I was by default always loading jQuery, whether needed or not. In Foundry 3 I’ve cut out jQuery, so any 3rd-party tool that needs it, like Eclipse, would need to load it on its own.

I’m speaking with Joe now to see if Eclipse loads jQuery itself via the Stacks API. He’ll likely be following up with you to get a live URL to look at.

I am a landscape architect by profession. Being from a design background, I found rapid weaver exciting and have been trying to explore it seriously. So the site I am working for (my firm)… is not yet complete. So I wouldn’t be able to share a live URL.

Thanks for following up…
I have no clue what jQuery is. :smiley:

Joe at Weaver Space needs. a live URL to help identify the problem. I don’t have a live URL. So not sure about a solution to this.

Hi @Sree,

Why not publish it to a folder on your live site? That way, your current live site won’t be altered and you can still show Joe what’s going on.

If that doesn’t work for you, e-mail me the Eclipse stack and your project file at info at and I’ll publish it on my staging server.


1 Like

There is no live site.
I have done a few pages with Foundry 2. This error popped up as I was reworking it with Foundry 3

I think that’s the way it is. I cannot load a banner video on the landing page.

1 Like

Is there an option to bring back jQuery to Foundation 3? It may affect other stacks as well, from different developers.

Hi @Sree,

My offer to send me the project file (and the Eclipse stack as I don’t have it) still stands.

I have a staging server with more than enough space to temporarily host your example so that Joe can take a look at it.


1 Like

Is there an option to bring back jQuery to Foundation 3?

I highly doubt that. One of the basic goals for F3 was to not have jQuery so that the framework would be lighter and faster.

I would take this up with the dev for the stack you are trying to use.

BTW, F3 has the Cinema stack that can act as a video banner. :wink:


No, jQuery being loaded by default will not be returning. I spoke with Joe yesterday and he said he doesn’t believe that is the problem. My advice would be to publish a test page for him as he asked you to do so that he can help you. You do not need to have a completed site to publish a test. You have to help him, so that he can help you.


I have tried Cinema stack. It is a video banner and does the same thing as the Eclipse Video stack - except that the video size gets reduced when I resize the windows (make the window smaller).

In Eclipse Video stack, the video’s width gets cropped when I resize windows… the video proportion(size) remains the same.

Not sure if I can get the same effect with Cinema stack.