New Shutter gallery is not publishing, but old ones work fine

Ok…so as a test, I changed the naming of Santerineross III and Dream, but not Fruit of the Secret God so I had a control.

When I changed the name, Dream also had no images- so by changing the name, that page no longer works! Now it looks like this:

This is how I named it and now it does not work, when it worked fine before I changed it:

I changed the name of the Santerineross III page to this:

I checked “Generate thumbnails” and published it and that made it look like this!

I unchecked “generate thumbnails” and republished, now we are back to this:

My control page, Fruit of the Secret God, I did NOT change the name of and it is still working fine

WHY? :weary:

Now I don’t know how to get Dream back- I am causing more damage to the site than I am fixing and I am so frustrated. :tired_face:

I tired that, but it did not work. The page still has NO images in the gallery. And by changing the name now Dream does not show any images either! I left the naming of Fruit of the Secret God as it was and it still works, but the new names have broken Dream and Santerineross III still does not work.

When I check “generate thumbnails” it publishes without the correct video header. I then unchecked it and republished, and while the header is back, but no images.

I am going to cry now.

Hi, can you use the address and check again? Everything works, just not the Dream copy.

Ok So I did an experiment. The problem is with the generation of the image thumbnails.

I added one of the new images to the existing “Dream” gallery. I can see it in the preview just fine.

I published it with “generate thumbnails” checked, which as always, completely breaks the page.

I unchecked “generate thumbnails” and the page looked the same as it did- but HERE is the interesting part— the new image that I added does not show up on the main shutter gallery page. There is no thumbnail for it. BUT if you go to the last thumbnail that shows up from Dream and open it, then click the next arrow- the image is actually there.

What is keeping the thumbnails from being generated? This would explain why the new gallery page is not working, since no new images added to any shutter page are generating thumbnails.

This is what happens to any shutter page when I publish with the “generate thumbnails” option checked:

Here is the preview view of the Dream page with the added new image (it is the one circled):

Please visit Dream | John Santerineross to see the published page- you will not see that new image

BUT if you click on the last thumbnail, you can click the next arrow and ta-daa! There it is!


The Dream copy was an EXACT copy of Dream, so it should have worked, but did not. It was an experiment to see if I could pinpoint the issue. Since Dream was working fine, I wanted to see if I could publish a copy of a page that was working fine… I copied Dream, published it and even though everything was exactly the same as Dream, it did not work. I have since deleted it because it, like Santerineross III (which I have temporarily removed as well) was not working.

Fruit of the Secret God has not changed
Dream has not changed

Any new images or new galleries do not work.

I don’t understand the problem. Please see my last post about adding an image to the Dream page- maybe you can help shed some light?

Thank you so much

Strange. I just tried your setup and added the last picture and it did show as thumbnail. Are you sure the “Generate Thumbnail” was checked for this copy of dream?


Yes. I checked “generate thumbnails” then published. When I do that it breaks the page. I then unchecked it and republished and at least the header works, but both ways there are no thumbnails.

Is THIS the image you see as a thumbnail in the Dream gallery?

I only see it as a thumbnail in preview, not on the published page. NO new images show up with thumbnails, which seems to be the issue.

Here is the preview:

Here is the published page:

See? It does not show up as a thumbnail, but if you click on the image “Pleasures of the Flesh” and click the arrow on the right to see the next image- it is there, just no thumbnail.

When I publish with the “generate thumbnail” box checked, it makes every page look like this!

Only when I publish it on my test-server.

On a site note: But I also see that you are mixing up themes and foundry pages etc. So you are using Foundry control center stacks on pages where Foundry is not the selected theme etc.

→ It might be better to redo the site using only one Framework like Foundry for all pages. Then you can rule out errors and actually avoid many more in the coming years.

If I were testing things, I would make a new page with folders and filenames correctly setup, with as little on the page as possible, and setup a new gallery as a test. Few variables to deal with in testing, the better.

:thinking: so it publishes with a thumbnail on your server?

Should I be yelling at my hosting service then? My blood pressure is through the roof trying to get this to work. :sob:

When I rename them as you indicated, the galleries do not work.

Please re-read my post above.

That said, the methods I outlined are the correct way to configure your site.

This one?

I tried naming them as you said and it made pages that DID work no longer work. Please see my post with screenshots here: New Shutter gallery is not publishing, but old ones work fine - #21 by HeatherEve

Long shot, possibly, but can you make sure none of your images have spaces or special characters in the filenames.

Ie. Web-safe filenames.

I’ve seen all kinds of weird scenarios caused by this issue. May not be the case here, but best to eliminate it, as well as following the advice above.

What is causing the lack of thumbnails? When I check “generate thumbnails” it breaks the page- no header, no gallery. When I republish with the “generate thumbnails” unchecked, the header is back but still no thumbnails. Which means no gallery.

When I added one single new image to the Dream page, it does not create a thumbnail for that image, but when you open the last image and click the arrow to the right, you can see that it is there. How do I remedy this?

All file names are just numbers. No special characters. I even tried renaming them with letters, but it seems that I cannot add any new images to ANY page, old or new, and have a thumbnail show up.

Yes, that post. Where I said to create a brand new page, with as little as possible on it for testing purposes, setting up a brand new gallery:

I made a new page.

I named it as you said.

I did nothing but add the Shutter stack and 7 test images.

I changed no settings, so generate thumbnails is checked.

There are no thumbnails still. New page. New gallery. I did everything you have said and it is still not working.

Here is what preview shows:

Click the link to see that THIS is what publishes!

Did you see my post about how when I add a new image to the existing (and working) Dream gallery that it does not show up in the gallery view (no thumbnail) but when you click on the last image and click the arrow to the right to see the next image it is actually there?

Great now we have a starting point that will help narrow in on things. Next thing to check – what version of PHP are you on currently? Have you updated recently? It would now be helpful to have a copy of your PHP error log file.

Ok great. Thank you. I will look and also share a copy but… Where do I find that? :upside_down_face: