Introducing the Carpenter templates for Foundry 🔨


The Carpenter pack is a set of pre-built templates that can be dragged and dropped from your Stacks library right into your project to help you build complex layouts like Banners, Call to Action sections and page Footers.


The Carpenter Template pack gives you access to 40 pre-constructed, complex layouts by just dragging-and-dropping them onto your page. Change the pre-populated text and images out for your own and instantly those complex layouts come to life.


The various templates included in this pack can be paired with your current content or matched up with other pre-made Carpenter templates to create unique layouts, pages and designs.

Over on the Foundry site we’ve got a look at each of the 40 different templates that are included in the Carpenter pack. Head on over to the Carpenter product page to browser through each screenshot!


Instant purchase :smiley:


Me too :slight_smile: it is really great!


Me three - though I’m mad because I just learned how to do some of this stuff and now I don’t have to j/k :smile:

1 Like

Awesome, Adam!

Will be on this first thing tomorrow. Does this replace Mason?



@jacksona – No, Carpenter does not replace Mason. They’re two different products, and each has their own product page on the Foundry site.

Mason Pack:

Carpenter Pack:

1 Like

Ditto ( bunch of unneeded characters)

Got this new Carpenter package. Good one! Thank you very much Adam.


Carpenter and Mason templates are great. I am using a Mason footer variation (MOL) for a large site I am completely redoing in Foundry. My only concern is that now my Library shows CTA 01 CTA 01 CTA 02 CTA 02 etc. One each for Carpenter and Mason.

1 Like

Search for Carpenter and you’ll get just the Carpenter templates, and vice versa. Or make custom Folders to contain each.


Priceless and so valuable. Adam, you’re star :star_struck:

1 Like

HI - I’ve tried to install this, but I keep getting the message “this stack is not currently installed - you need to re-install it to use it.” I’ve done this twice and I still get the same error message. (Not so with the Mason stack.) What is happening and how do I resolve it?

Thank you.

Have you updated to the latest version of Foundry v2?

Ahh … that will be it. How do I know which email I used to make my original purchase of Foundry (I can’t find my original invoice, but seem to have two of my emails linked to Elixir)?

I’ve now upgrade to Foundry version 2 … but I’m still getting the same error message.

You have to run the Stacks updated as mentioned in my post I linked to above. Run the updates inside of Stacks.

OK - thank you. I hadn’t noticed that the stacks hadn’t all updated (despite pressing update all); one from another developer refuses to update but I’ve done the elixir ones manually now and it works fine. Thank you again.