Replace index.html with index.php

I had a flag popup telling me that I had two index files and recommending I remove one. Unfortunately I removed index.php before I read the excellent guidance advising what caused my initial problem, i.e., I added a Form for Contact. Too late, I removed the index.php, when I should have removed the index.html. Soooo, how do I correct my error? i.e., get the proper index.php in place and remove the index.html?

Follow point 2 here, and then republish the page.

1 Like

The good news is that I found and read your guidance independently. The bad news is that I didn’t find it until AFTER I had already deleted the .php file, when I should have deleted the .html file. So, now I have the wrong index. I’m not seeing where your guidance explains how I replace the .html file with a proper .php file? Thanks.

Re-read this post fully.

1 Like
  1. Go and delete the index.HTML file.
  2. Republish your page.
1 Like

Hi Adam. Thanks for sticking with me on this. I have done all of your suggestions to now, however, last thing I did was delete the index.html file and then republish after I had replaced my Contact page with a total new one, hoping that might help get things organized. Still no go. Now my hosting site has no index file. I had avoided deleting it, until you specifically said I should bc I interpreted your guidance to say I shouldn’t do that. I stand corrected, but now my site is more messed up than before. While my site wasn’t working properly, when I started this current effort, my immediate objective was to add a Contact page, which I’ve now done (2x), but now site totally incapacitated.

One thing I’ve found that may be causing me grief is on my Publishing Page, where I’m showing my website <>, but I may be missing the fact that it is a subdomain to my main domain:

I recall in the past that I could attach something here, but I no longer see that. I have a screenshot of that Publishing Page that I thought I would send, but I no longer see that capability. Thanks, again, of sticking with me.

Did you delete the index.php file from the root of your site, or the contact folder? (Whatever you’ve called it). It sounds like you’ve deleted from the root, rather than the folder for the page with the form.

Assuming your publishing settings are OK (and I’m guessing that’s how the index.php got there in the first place), try to Republish All Files

I’d then check each and every folder for that site, and where you have BOTH .html AND .php index files, delete just the .html.

1 Like


Obviously, I have no idea how your RW site is structured, but you should also check you haven’t fallen foul of the ‘gotchas’ in points 3 and 4 in my pinned post, referenced above…

1 Like

I’m happy to report that with a bit of help from the support team at Chillidog, I’ve corrected my structural problems, which now allows my site to show up properly. I have two problems I’m hoping you can provide necessary guidance…

  1. I added a new page for Contact. It works from Home but not from the other pages in the NavBar. Seems like I’m missing something simple. Your thoughts?

  2. When I upload the site to my Chilldog server and then click on Visit, I go to instead of For background I prototyped this site in my URL, before uploading to its proper URL.

Thanks for any insight or guidance you may have for me.

  1. Is your NavBar in a Partial? (That way one update changes it on each page that it appears). Could be your link is “relative” rather than “absolute”, although you should be using RW’s page navigation dropdown in the Link dialog. TBH, it could be any number of things, and without someone looking at your project file, it’s impossible to be 100% certain what it is.

(I should add at this point that I don’t load up other people’s project files, so someone else would need to take a look).

  1. You need to make sure your site is correctly set up both in your Publishing Settings AND in Settings, General in the left-hand pane:

CleanShot 2024-02-17 at 12.21.13@2x

The first one tells RW how to publish your project, the second one tells it where to Visit, once published - I suspect that’s where you’ve still got referenced.

I remember reading about “Partials,” when I started, but I’ve not used it. I’ll re-review to see if applicable. Thanks for this guidance.

I had not changing the Settings, General. I have now, and you were spot on. Thanks, again, for great guidance.

You’re definitely going to want a Partial for the NavBar, otherwise you’ll need to configure it for each page of your site.

Partials are also a great way to make sure your site style is consistent across pages, too.

It’ll save you a ton of time.

So, as indicated, I was finally able to dedicate myself to re-reviewed the videos and docs in an effort learn about how to make a “Partial.” I’ve watched the first five again from start to finish, but I’ve not yet found any instructions for Partials. I’ve also done a search, and the attached comes up, suggesting that I should find Partials in the Control Center docs, but no luck there either.

I wonder if you could point me in the direction enabling my learning about how to create and manage partials.


Partials are a part of Stacks, not Foundry. Visit the Stacks site for documentation and videos on using Partials.

Noted. Thanks for this guidance.