Shutter Stack not publishing

Hey Gang! Finally got my email confirmed for posting on this forum so this is my first post…

I am building a site using the “Kinfolk” theme by Michael David Design. I am trying to use the Elixir Shutter Stack for multiple gallery pages on the site, and while it previews just fine it does not show up at all (white page with no mouseover or interactables) once published.

I feel like I must be missing something very basic, though after a week of troubleshooting it myself, and reviewing other Shutter Stack topics here I am still coming up empty. Any thoughts or advice from the group would be welcome, and I realize there may be more information needed…

current WIP page: BIRDS | wildlife

Thanks all!

If it’s live, a link to the published site?

Sorry, was publishing it just now temporarily as it is not live yet, but realized that there would likely be a want to try a link first hand:

There is a lot of stub in and “work in progress” on the site as a whole, but this is a link to one of the galleries.

Had a quick look in two different browsers. The HTML code is truncated as if it didn’t all publish completely. I doubt it has anything to do with Shutter.

If you view the source on the published page you can see it terminates just where Shutter starts.


That makes sense as earlier I had the pagination links below the Shutter Stack and they didn’t publish either. When I placed them before the Shutter Stack they show up just fine…

I am baffled…

Hopefully someone else should chime in over the next day. I’ve not seen anything similar before. Maybe check the exported index.php on the server to see if it is complete. You could also try removing stacks one by one and seeing if the page is still incomplete (tedious but that’s how I would attack it).

There maybe some theme/stack compatibility issue but if it works in preview that doesn’t sort of make any sense.

I appreciate the feedback and the quick replies, thanks so much.
I will give your stack removal test a go, but in the meantime hopefully others may have additional thoughts.

As someone who has a small collection of bird paintings I’m keen to see the result!

1 Like

Please select publish all and then check again.

1 Like

Good morning @Benthompsonart

A few questions to get us started:

  • What version of PHP is your server running?
  • Are you using JPG images?
  • Are you using batch processing or drag-and-drop?

When setting up Shutter did you follow along with the Tutorial video and replicate how it is setup? If not, give that a shot. If you followed the tutorials step-by-step but are still having problems, please let us know. When you do you’ll need to provide us with a ZIP file containing the following items:

  • Your project file (this is the file you open in RapidWeaver to edit your site)
  • A folder containing all of the images you’re using in the gallery that is having problems.

To send this ZIP file to us you’ll need to use a service like WeTransfer to create a download link, as uploading the ZIP file here, or sending via email, willl be too large. Once you make that download link post it here or email it to me at adam at elixirgraphics dot com

1 Like

Yup, usually my first choice for debugging and in this case I think I must have tried it about 4 times

1 Like

Hey Adam,

Thanks for jumping in sir I appreciate it

  • My PHP version is currently 5.6, though I have the option to upgrade to one of three others (7.4, 7.4 or8.0)
  • I am using jpg Images that have been compressed after the fact with Squash
  • I am using drag-and-drop

I did follow the tutorial initially when setting up the page(s), and in fact re-watched it last night when trying to sort through this, though I certainly might have missed something.

I have sent you the requested zipped file including the project file and a folder with all of the images in all three galleries (as all three are running into this problem). If you prefer to just have one of the folders worth of images I am happy to re-zip using just one of them.

Thanks all for your help thus far gang, it is much appreciated! I am happy to be embarrassed by a simple solution, and I hope that is all this comes to :wink:

You should upgrade to v7.3 or v7.4

Images are quite large. I looked through the Birds folder as an example – you’re averaging about 1mb per image. This is too large for the web, especially for JPGs. Additionally you’re using 300dpi images. They need to be 72dpi.

With very little compression, I simply changed the image from 300 dpi to 72 dpi, I saved about 300kb. This was with keeping your original dimensions of 1,500 x 1,164 px.

Sizing it down to say 1,000 x 776px saved another 400kb.

You’re going to need to take a look at these image sizes and compression again I think.

These are things I mentioned in my original email reply to you on July 18th.

I published your project file as-is to my server and everything is looking just fine. Shutter is processing and displaying the images as it should. There are two differences between what I’ve published and your setup –

  1. I don’t have the theme you’re using. If you’d like me to test it, send it over like you did your project file and images.
  2. I published it to my server, where I run PHP v7.4 currently.

I even used your images as-is without modifying, resizing or compressing them.

Again, I performed this just now, as well as on July 18th when I replied to your original email as well. In both instances Shutter seems to be working A-OK.

The first step I think you should take is to switch to PHP v7. It can take the host a little while usually to update to a new version after you request it, so give it a little time, then retest your page.

If it still is not working your host may not allow, or have installed, the PHP that is sizing the images. In that can you may need to use the manual thumbnail creation. In fact you could turn off thumbnail creation as a test and use manual thumbnails to see if that clears things up.

Also, if you’d like to send me the theme using, as I said above, I’d be willing to test it out.

If you’d like to view the test pages I’ve made you can see them here:

Today’s test:

Test from July 18th:

1 Like

Additionally – I really enjoyed looking at the beautiful bird paintings by Don. Gorgeous!

1 Like

Lots of good information here Adam, thank you for taking the time to get it all down.

First and foremost let me apologize as I never received your aforementioned email on July 18th, so I definitely don’t want you to think I posted here after the fact with the same problem hoping for a different answer! :wink: I believe there is a problem with my other email as I was not allowed to sign up for the forum using it so that might be part of the issue here.

Ugh, so that is definitely part of the problem as I have another folder with these images at 72 dpi and mistakenly used the full res images. (*facepalm)

I have applied for an upgrade to PHP 7.4 on the server, which I have to imagine is 90% of this issue at the outset, so thank you for asking about that specifically.

I will try applying all of the above before troubling you further by sending you the theme, but I will do so if the problem persists.

Thanks again for detailed feedback and I appreciate all here taking the time to help an illustrator moonlighting as a web designer!

I shall update the thread once I get the chance to try these later tonight

P.S. Thanks for the kind words regarding the paintings, they are actually my father’s and I am building this website as a surprise for him to be able to share and sell his works in retirement. (This probably means future adventures as I build the commerce portion of the website) (*cold sweats)


It is not a bother. I suspected you might not have received the email, but wanted to make mention of it in the event you want to see if it is in your spam folder or something. Glad you got signed up on the forum though.

Feel free to shoot me an email with that theme and I can test that pretty quickly.

Once your father’s store is all setup, please let me know!

1 Like

Ugh… you were right Adam:
It appears The host must not have the PHP to allow image sizing and I cannot rely on the “Generate Thumbnails” selection in the stack. Looks like I get to exhibit “complete control” of the process and create thumbnails for every image…

I appreciate the suggestion as a quick test proved to sort this out rather quickly, even if the actual solve-per-image time will require a bit more time than that :wink:

Incidentally, it appears that Chrome does not render my body copy in the same chosen font as Firefox and Safari… any reason this would be true? wouldn’t that font be embedded in the theme or am I naïve in thinking this? (I understand if you cannot speak to other’s themes, I just honestly don’t know if this is a browser issue…)

Thanks again for the help and I will get to cracking on the Thumbnail generation in the meantime!

Have a look at Retrobatch. It’ll save you a ton of time.

1 Like

While this might seem like the long way around if your host doesn’t support basic PHP image resizing, which is now one of the base extensions (IMO) I’d suggest now is a good time to look for a better host. Even the cheap as chips hosts that I use for testing have it as standard.

I understand that lots won’t add ImageMagick, but nowadays I don’t know of any that don’t/won’t support the basics.

They might have a good reason for this, but it might also be a sign of further restrictions that you might run into down the line.

Can you send me a copy of your PHP error log file from your server? Your host should be able to provide you instructions, whether through their documentation or by asking them, on where to find this file.

Additionally, can you let me know who the host is?

This is one you’d need to take up with the theme developer. They’ll be able to narrow in on your problem faster than me since it is their theme.